Slowly losing frogspawn

Discussion in 'ASAP' started by kstafford003, Jan 24, 2015.

to remove this notice and enjoy 3reef content with less ads. 3reef membership is free.

  1. DSC reef

    DSC reef Giant Squid

    Joined:
    Dec 16, 2012
    Messages:
    3,814
    Location:
    Cocoa, Florida
    My euphyllia love mysis shrimp. I feed Dr. G's mysis max and frozen mysis.
     
  2. Click Here!

  3. oldfishkeeper

    oldfishkeeper Giant Squid

    Joined:
    Aug 13, 2012
    Messages:
    7,660
    Location:
    Cincinnati
    that's a little concerning that your credit cards get stolen every 6 months or so?? is that from making purchases on line?
     
  4. kstafford003

    kstafford003 Feather Star

    Joined:
    Oct 20, 2010
    Messages:
    769
    Location:
    Austin, TX
    Oh ok. I have never heard of those. I'll check them out.

    That's what I have been feeding. Do they show feeding response? Mine don't really do anything when I feed them. The acans swallow the stuff but the euphyllias just look the same as usual and the shrimp blows off.

    It concerns me too lol. I had someone buy a vacation to mexico once, plane ticket and all. This last one was just for $7 dollars and the CC company called me about it. I'm glad they did or I probably wouldn't have noticed. I purchase everything online with the same card so who knows how it keeps getting stolen. Heck target even got hacked so I'm sure little mom and pop shops get hacked.
     
  5. kstafford003

    kstafford003 Feather Star

    Joined:
    Oct 20, 2010
    Messages:
    769
    Location:
    Austin, TX
    Well the frogspawn is looking much better. I'll wait a couple more days to make sure. The polyp is almost fully extended and the rest of the tank looks better too.... except for an encrusting monti. All of its polyps are either closed completely or half receded. I increased the mag from 1200 to 1350 over two days. Did this cause the recession? I am doing a water change today. Will the monti recover or should I take further action. I have inspected the monti for the black bugs I had and can't find any (I am ordering interceptor today just in case).

    Thanks again for the help. Maybe one day I'll get this hobby down.