problem with chiclids

Discussion in 'Cichlids' started by biggruntav8tor, Jun 20, 2011.

to remove this notice and enjoy 3reef content with less ads. 3reef membership is free.

  1. biggruntav8tor

    biggruntav8tor Plankton

    Joined:
    Jun 20, 2011
    Messages:
    4
    Hey yall new to the forum's and i know this is probably an algae question but at the same token i have a 220L south american chiclid tank, im getting the brown algae which from my research is from too much light? i dont turn on the light in the tank but there are two windows across the room from it. we have about 12 fish in the tank and the tank is 2meters long. so there is plenty of room for the fish, plenty of rocks in the tank for hiding and running small rocks in the bottom of the tank. got a big pump not really sure on the type but it has several trays inside the tank. i have one albino pleco in the tank for cleaning. sorry im new to the fish tank thing as well my wife takes lead on this. ive used a gravel vac to get rid of some of it but it seems to be covering the rocks and the bed again. should i get more pleco's or is there some other way to get rid of it. i will try and get more info on the fish in the tank but all see to work well with each other. i also have a little flow thing ( i think ) to push the water around through out the tank as well. I would like to add more but afraid if i introduce new fish with this stuff will it be ok? Is there something im doing wrong or not quite right?? any help would be appreciated. thank you.
     
  2. Click Here!

  3. 2in10

    2in10 Super Moderator Staff Member

    Joined:
    Aug 6, 2009
    Messages:
    19,258
    Location:
    Sparks, NV
    It should be fine to add more fish and yes it is an alga. Feed less if you can or add more plecos.
     
  4. biggruntav8tor

    biggruntav8tor Plankton

    Joined:
    Jun 20, 2011
    Messages:
    4
    Thanks 2in10 ill try to add a couple more and see if it works out, prob take a while but we'll see. thanks again
     
  5. mamafish

    mamafish Plankton

    Joined:
    Aug 30, 2011
    Messages:
    1
    hey 2in10, i was refered to you by sierra aquatics, i'm new here so i don't know how to post questions......i have a krib cichlid in my tank, been there about 3-4 days and he's not really eatting his pellets....first one i've ever had and i don't know what to do really. if you could get back to me, tell me how to post, i don't want to loose my my fish i need help i got questions for you....thanks, mamafish