new crocea questions

Discussion in 'Clams' started by metzeric, May 24, 2008.

to remove this notice and enjoy 3reef content with less ads. 3reef membership is free.

  1. Jason McKenzie

    Jason McKenzie Super Moderator Staff Member

    Joined:
    Mar 23, 2003
    Messages:
    5,538
    Location:
    Vancouver, BC,Canada
    I'm sorry but what do Mg Levels have to do with the health of a Clam.

    Clams tend to take time to acclimate to new light.
    Do you know what light it was under at the LFS?
    If it was more or less intense it may take a few days to come around.

    Could you post a picture?

    J
     
  2. Click Here!

  3. ollie51

    ollie51 Feather Duster

    Joined:
    Nov 9, 2007
    Messages:
    218
    what size tank do you have ? i have 6 maximas(5 approx 3 inches)1 is about 6 inches & 1 crocea about 5 inches i keep my calcium at 1500 i have500 watts mh ,200 watts pc on a 75 gal calcium levels need to be high clams suck it right up but i would would think 2/175 mh should be fine
     
  4. coral reefer

    coral reefer Giant Squid

    Joined:
    Jan 9, 2006
    Messages:
    4,860
    Location:
    Wonderland
    Give your clam some time is all. Acclimation process unfortunately tends to make us think and do irrationally. With proper water parameters, and lighting, it should do fine, UNLESS it was already damaged/injured in the collecting ans shipping processes.
    Nitrates around 10-15ppm will help as well as no predators ie. fish, worms, snails etc.!
     
  5. metzeric

    metzeric Astrea Snail

    Joined:
    Mar 19, 2008
    Messages:
    39
    the tank is a 120 the clam has only been in for 5 days there are no predator fish but there are snails hermit crabs and a decent size bristle worm the clam is up high the snails are small ive seen them on the outside of the clams shell but nothing else
     
  6. GuitarMan89

    GuitarMan89 Giant Squid

    Joined:
    Mar 31, 2008
    Messages:
    5,736
    Location:
    Wilmington, DE
    I also just bought a crocea, mine opened right up. I had it at the bottom on top of shell and it attached itself within 4-5 days. However, I just moved it higher in the tank. I know from what many people have said in the clam threads, that my lighting may not be high enough, but we will see. So far, he seems to be doing fine.