Mighty Mite not giving 0 TDS?

Discussion in 'Air, Water & Ice' started by MrOcean, Apr 14, 2011.

to remove this notice and enjoy 3reef content with less ads. 3reef membership is free.

  1. MrOcean

    MrOcean Bristle Worm

    Joined:
    Dec 9, 2010
    Messages:
    139
    Location:
    North East
    I bought a Mighty Mite last month. I've used it to make about 60 gallons of water so far. I was getting 0 TDS with tap water coming in at over 500 TDS. Recently I've been getting around 6 TDS.

    I use a Rubbermaid container to store the water in. Could the TDS reading be coming from the container? Could I have already gone through the filters and need replacing (I sure hope not lol)...? I'm new to this whole RO/DI thing so any help is appreciated!

    Also, is the quality of this water so horrible for a soon to be softie/LPS reef?
     
  2. Click Here!

  3. airwaterice

    airwaterice 3reef Sponsor

    Joined:
    Aug 4, 2009
    Messages:
    13
    500 TDS feeding that unit is pretty high. Your filters may be exhausted already.. but to be sure.. check the water coming straight out of the DI cartridge.
    Get back to me @
    sales@airwaterice.com
     
  4. M-Ocean Man

    M-Ocean Man Flame Angel

    Joined:
    May 4, 2010
    Messages:
    1,545
    Location:
    Dirty Jerz
    500 TDS!?!?!?!?!

    Where is that water!?

    I thought mine was bad at about 200 TDS!

    The water where I work is about 335! But 500 is pretty bad.

    What is the water pressure there? What is the TDS coming out of the RO membrane? If this is higher than a few TDS (say higher than 5 or so TDS) then your DI resin will be exhausted rapidly.

    Do you have colorchanging resin on there? Is it now brown/amber?
     
  5. Renee@LionfishLair

    Renee@LionfishLair 3reef Sponsor

    Joined:
    May 16, 2010
    Messages:
    2,895
    Location:
    Coastal So. cal
    Are you saying the O TDS water is now reading 6 in the rubbermaid or the water coming straight from the RO/DI is now 6 when it read 0 60g ago....
     
  6. mikev15101

    mikev15101 Purple Spiny Lobster

    Joined:
    Jan 18, 2009
    Messages:
    461
    Location:
    Philadelphia
    Provide the above information, with more clarity we will get down to the bottom of your issue.
     
  7. blackraven1425

    blackraven1425 Giant Squid

    Joined:
    Mar 1, 2010
    Messages:
    4,780
    If the RO membrane is cheap (probably is), it could be something like 95% rejection. That would be 25 TDS out of the membrane, which would mean your DI would likely already be exhausted.
     
  8. Click Here!

  9. Jgut3

    Jgut3 Fire Worm

    Joined:
    Sep 8, 2010
    Messages:
    158
    Location:
    Alabama
    500 tds your filter wont last as long as the recommended replacement time frame. Its prolly exhausted.
     
  10. jtr38230

    jtr38230 Skunk Shrimp

    Joined:
    Nov 21, 2010
    Messages:
    271
    Location:
    Tennessee
    I think that they are saying the tap water is at 500 tds and they was getting 0 but now its 6 tds. Try testing the water out of a clean cup instead of the rubbermade tote. It is more than likely the tote that is dirty.
     
  11. cosmo

    cosmo Giant Squid

    Joined:
    Nov 17, 2011
    Messages:
    6,166
    Location:
    southeast ohio O-H....
    +1 prob just your tote
     
  12. stepho

    stepho Panda Puffer

    Joined:
    Dec 2, 2008
    Messages:
    2,118
    Location:
    Orlando FL
    Hopefully this issue has been solved, this thread is from April of last year. ;)