Eshopps psk 100h problems

Discussion in 'Eshopps Inc.' started by dmfirefighter7, Mar 4, 2012.

to remove this notice and enjoy 3reef content with less ads. 3reef membership is free.

  1. dmfirefighter7

    dmfirefighter7 Plankton

    Mar 4, 2012
    I bought this skimmer a few days ago, it has been up and running for a couple of days. I have it on my 29gal sump , I had to attach a hose to the intake to extened and get water into the main chamber. It will work for a short time and get micro bubbles, but after a couple hours I loose the water going into the intake , loose the siphon, then the bubbles stop.

    I have tried to use the water level adjustment but it will not do anything.

    I need some help, I don't know if the extension I have it making the skimmer work improperly, bad pump, bad model skimmer...any help would be nice.

  2. Click Here!

  3. reefmonkey

    reefmonkey Giant Squid

    Mar 3, 2010
    SE South Dakota
    Welcome to 3reef!

    When you say you added a hose it makes me wonder if there isn't air getting in at the connection one way or another and causing the break.
    I have a 100H that has worked flawlessly for a couple of years now. Of course I haven't modified it in any way and have it set up per manufacturers instruction.

    Is there any way to get the water level up so that the skimmer can be set up properly?

    If no. Then I don't know how to help you. But please, if it doesn't work out don't be "one of those people" that mod's a piece of equipment, finds it doesn't work like they want and then go all over the forums calling the manufacturer crap. Not saying you would but I've seen it time and again.
  4. lukeeluciano

    lukeeluciano Astrea Snail

    Feb 19, 2012
    When I got my 100H, I had to push the water adjuster PVC pipe all the way down in the slot and there was some resistence from the red rubber O-ring. If I didnt do that, the adjuster would not work.