Algaefix marine killed my fish

Discussion in 'ASAP' started by RobK13090, Feb 2, 2009.

to remove this notice and enjoy 3reef content with less ads. 3reef membership is free.

  1. 10acrewoods

    10acrewoods Fire Goby

    Joined:
    Dec 2, 2008
    Messages:
    1,337
    Location:
    Carbondale Il
    this is one of the reasons I try to stay as natrual as possible. quick fixes usualy only produce poor results in the long run (in the short run in your case). Too bad you had to find out the hard way.
     
  2. Click Here!

  3. RobK13090

    RobK13090 Astrea Snail

    Joined:
    Feb 1, 2009
    Messages:
    71
    Location:
    ohio
  4. bc219

    bc219 Millepora

    Joined:
    Oct 21, 2008
    Messages:
    937
    Location:
    Mishawaka, IN
    I'm jealous that you're in the midwest and can actually consider breaking ground to bury something this time of year! Here we'd break the shovel! I'd just flush em!!
     
  5. el_sillo

    el_sillo Spaghetti Worm

    Joined:
    Dec 10, 2008
    Messages:
    183
    Location:
    McAllen Tx
    thats strange, i used the same product to get rid of the blue-green algae and i still use it every week to just simply prevent it and i haven't had any loses. you might wanna check your params or maybe you did overdose, thats really strange because there product does state that it will not harm any fish, coral or invertebrates. maybe that might not be true?
     
  6. PharmrJohn

    PharmrJohn The Dude

    Joined:
    Jun 29, 2008
    Messages:
    4,615
    Location:
    Shelton, Washington
    Sorry about that brother. K+ for your losses.
     
  7. Tangster

    Tangster 3reef Sponsor

    Joined:
    Aug 16, 2006
    Messages:
    5,644
    Location:
    Va/Ct
    Well from what you described about the algae it sounded like diatoms thats about the only thing I know of that will leave a brown dusting when it dies off ! and when any plankton dies off it will deplete oxygen rather quickly. This algae control stuff would not have been what I would have used on the diatom bloom .

    Do you does D/T's and have you tested the R/O water ? I have seen more then a few membrane to have the seal split and simple tap water to blow by and leak past the outlet O rings .Or the membrane could just be worn out and or not a high enough rejection rate Diatoms feed only on silicates suspended in the water or had you just added any new rocks or sand ?
     
  8. Click Here!

  9. RobK13090

    RobK13090 Astrea Snail

    Joined:
    Feb 1, 2009
    Messages:
    71
    Location:
    ohio
    the newwest addition to the tank was the live rock which i didnt have much, i dont have quite as much airiation as i wished so i have a feeling it was a lack of advanced setup kinda thing.
     
  10. mirandacollc

    mirandacollc Flame Angel

    Joined:
    Aug 25, 2008
    Messages:
    1,505
    Location:
    Lebanon ME
    I used this stuff a hnadfull of times. I dident notice any difference and then even went to the max dose and still nothing. I got no results from it and no problems with it. I thought it was more a snake oil if you ask me. Sorry for your loss. I just had my tank partly crash a few weeks ago and am back on track. Its like being violated! Nobody wants to experience it and stinks when it happens. K+
     
  11. RobK13090

    RobK13090 Astrea Snail

    Joined:
    Feb 1, 2009
    Messages:
    71
    Location:
    ohio
    API said they would test the bottle if i sent it in..the question is, do you think they will admit to a faulty product if it just so happens to be a dud? I cant picture them owning up to the problem should it come to be their fualt and actually send me a cash amount or replacement fish judging by the "its not my fault at any cost" attitude i got over the phone. The so called hobbyist i spoke to had the nerve to say it was an unrelated disease.
     
  12. bmshehan

    bmshehan Fu Manchu Lion Fish

    Joined:
    Jan 4, 2008
    Messages:
    1,904
    Location:
    Columbus, Indiana
    I think you probably won't get the answer you want but good luck!! Worth a try I guess...